CVE-2026-42458: OpenMage magento-lts · Improper Neutralization of Alternate XSS Syntax
Affects OpenMage magento-ltsSource CVE Database V5
Not known to be exploited · CVSS 5.3 Medium : upgrade to 20.18.0 when convenient.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 25% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 20.18.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 15 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade magento-lts and openmage/magento-lts to 20.18.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| OpenMagemagento-lts | Affected
| Fixed in
|
GitHubopenmage/magento-ltspkg:github/openmage/magento-ltsOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade to OpenMage magento-lts version 20.18.0 or later, where this vulnerability is fixed. Since the vendor advisory indicates the issue is resolved in 20.18.0, applying this official fix is the recommended remediation. No additional mitigation guidance is provided or necessary.
Description
Magento Long Term Support (LTS) is an unofficial, community-driven project provides an alternative to the Magento Community Edition e-commerce platform with a high level of backward compatibility. Prior to 20.18.0, there is a reflected XSS vulnerability under admin panel -> System -> Import/Export -> Dataflow - Profiles. This vulnerability is fixed in 20.18.0.