Skip to main content
VulnerabilityPublished Updated

CVE-2026-42509: Apache Wicket · Cross-site Scripting

Affects Apache WicketSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.1 Medium · fixed in 10.9.0 : update Apache Wicket when convenient.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 3.1 base score
6.1Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 29% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 10.9.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
Apache Software FoundationApache WicketAffected
  • >=8.0.0 <=8.17.0
  • >=9.0.0 <=9.22.0
  • >=10.0.0 <=10.8.0
Fixed in–
Mavenorg.apache.wicket/wicket-corepkg:maven/org.apache.wicket/wicket-coreOther threatsAffected
  • =8.0.0
  • <=8.17.0
  • =9.0.0
  • >=10.0.0 <=10.8.0
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade Apache Wicket to version 10.9.0, which contains the official fix for this vulnerability. No other mitigation or temporary workaround is indicated in the available data. Patch status is confirmed by the vendor recommendation to upgrade.

Description

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Apache Wicket. This issue affects Apache Wicket: from 8.0.0 through 8.17.0, 9.0.0, from 10.0.0 through 10.8.0. Users are recommended to upgrade to version 10.9.0, which fixes the issue.

References

Community reviews

Loading reviews…