CVE-2026-42535: Apache HTTP Server · Resource Exposure
Affects Apache HTTP ServerSource CVE Database V5
Not known to be exploited · CVSS 9.1 Critical · fixed in 2.4.68 : patch Apache HTTP Server as a priority.
Data as of 29 Oct 2026, 19:04 UTC
- EPSS
- 0.5% chance of exploitation in 30 days – higher than 45% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.4.68
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 8 Jun 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Apache Software FoundationApache HTTP Server | Affected
| Fixed in– |
Apacheapache/httpdpkg:rpm/apache/httpdOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in Apache HTTP Server version 2.4.68. Users should upgrade to this version to remediate the vulnerability. No other mitigation or temporary workaround is indicated in the available data.
Description
A path handling vulnerability exists in the mod_dav_fs module of Apache HTTP Server versions 2.4.67 and earlier. This flaw allows a WebDAV content author to manipulate trusted DAV property databases, which can lead to child process crashes. The issue is resolved in version 2.4.68, and users should upgrade to this version to mitigate the risk.