CVE-2026-42536: Apache HTTP Server · Heap-based Buffer Overflow
Affects Apache HTTP ServerSource CVE Database V5
Not known to be exploited · CVSS 7.5 High : upgrade to 2.4.68 soon.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 1.0% chance of exploitation in 30 days – higher than 63% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.4.68
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 8 Jun 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: evidence found.
Public exploit code: GitHub proofs of concept
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), GitHub proofs of concept, the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade apache/httpd to 2.4.68.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Apache Software FoundationApache HTTP Server | Affected
| Fixed in– |
Apacheapache/httpdpkg:rpm/apache/httpdOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in Apache HTTP Server version 2.4.68. Users should upgrade to this version to remediate the vulnerability. As a temporary mitigation, if the mod_xml2enc module is not essential, it can be disabled by commenting out the LoadModule xml2enc_module directive in the Apache configuration and restarting the service. Note that disabling this module may cause failures in configurations relying on XML encoding features such as mod_proxy_html. Red Hat strongly recommends applying the official patches provided in their security advisories for affected RHEL versions.
Description
Heap-based Buffer Overflow vulnerability in Apache HTTP Server with mod_xml2enc, xml2StartParse, and untrusted content This issue affects Apache HTTP Server: from 2.4.0 through 2.4.67. Users are recommended to upgrade to version 2.4.68, which fixes the issue.
References
- httpd.apache.org/security/vulnerabilities_24.html (opens in a new tab)
- openwall.com/lists/oss-security/2026/06/08/9 (opens in a new tab)
- access.redhat.com/security/cve/CVE-2026-42536 (opens in a new tab)
- bugzilla.redhat.com/show_bug.cgi?id=2486411 (opens in a new tab)
- security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-42536.json (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:47046 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:34109 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:42828 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:41906 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:25042 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:53371 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:56868 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:56869 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:62165 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:66323 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:67152 (opens in a new tab)