Skip to main content
VulnerabilityPublished Updated

CVE-2026-42543: dfir-iris iris-web · Trusting HTTP Permission Methods on the Server Side

Affects dfir-iris iris-webSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 4.3 Medium : upgrade to 2.4.28 when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
4.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 6% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.4.28
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade iris-web and dfir-iris/iris-web to 2.4.28.

Affected software

ProductAffectedFixed in
dfir-irisiris-webAffected
  • <2.4.28
Fixed in
  • 2.4.28
GitHubdfir-iris/iris-webpkg:github/dfir-iris/iris-webOther threatsAffected
  • <2.4.28
Fixed in
  • 2.4.28

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade to dfir-iris iris-web version 2.4.28 or later, which contains the patch addressing this vulnerability. Patch status is not explicitly confirmed beyond the version note, so verify with the vendor advisory for current guidance.

Description

IRIS is a web collaborative platform that helps incident responders share technical details during investigations. Versions prior to 2.4.28 are vulnerable to a cross-site request forgery attack, because they use the HTTP method `GET` to change state on the server. Version 2.4.28 contains a patch.

References

Community reviews

Loading reviews…