Skip to main content
VulnerabilityPublished

CVE-2026-42550: flightphp core · SQL Injection

Affects flightphp coreSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.8 High : upgrade to 3.18.1 soon.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 3.1 base score
8.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 39% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.18.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade core and flightphp/core to 3.18.1.

Affected software

ProductAffectedFixed in
flightphpcoreAffected
  • <3.18.1
Fixed in
  • 3.18.1
Packagistflightphp/corepkg:composer/flightphp/coreOther threatsAffected
  • <3.18.1
Fixed in
  • 3.18.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade FlightPHP core to version 3.18.1 or later, where this SQL injection vulnerability is fixed. There is no indication of alternative mitigations or temporary workarounds. Patch status is not explicitly stated but the fix is available in version 3.18.1.

Description

Flight is an extensible micro-framework for PHP. Prior to 3.18.1, SimplePdo::insert(), SimplePdo::update(), and SimplePdo::delete() build SQL statements by concatenating the $table argument and the keys of the $data array directly into the query, with no identifier quoting and no validation. When an application forwards user-controlled data shapes to these helpers — a common and documented pattern, e.g. $db->insert('users', $request->data->getData()) — an attacker can inject arbitrary SQL by crafting malicious array keys. This vulnerability is fixed in 3.18.1.

References

Community reviews

Loading reviews…