Skip to main content
VulnerabilityPublished

CVE-2026-42588: Apache ActiveMQ Broker · Improper Input Validation

Affects Apache ActiveMQ BrokerSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.1 High : upgrade to 6.2.6 or 5.19.7 soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
8.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.7% chance of exploitation in 30 days – higher than 54% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 6.2.6, 5.19.7
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 1 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    Public exploit code: GitHub proofs of concept

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), GitHub proofs of concept, the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade Apache ActiveMQ Broker and Apache ActiveMQ All and Apache ActiveMQ and Apache Software Foundation/org.apache.activemq:activemq-broker and Apache Software Foundation/org.apache.activemq:activemq-all and Apache Software Foundation/org.apache.activemq:apache-activemq to 6.2.6 or 5.19.7; org.apache.activemq/activemq-broker to 5.19.7.

Affected software

ProductAffectedFixed in
Apache Software FoundationApache ActiveMQ BrokerAffected
  • >=6.0.0 <6.2.6
Fixed in
  • 6.2.6
Apache Software FoundationApache ActiveMQ BrokerAffected
  • <5.19.7
Fixed in
  • 5.19.7
Apache Software FoundationApache ActiveMQ AllAffected
  • >=6.0.0 <6.2.6
Fixed in
  • 6.2.6
Apache Software FoundationApache ActiveMQ AllAffected
  • <5.19.7
Fixed in
  • 5.19.7
Apache Software FoundationApache ActiveMQAffected
  • >=6.0.0 <6.2.6
Fixed in
  • 6.2.6
Apache Software FoundationApache ActiveMQAffected
  • <5.19.7
Fixed in
  • 5.19.7

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

If you cannot patch yet, restrict access to the Jolokia JMX-HTTP bridge to trusted users only and monitor for suspicious activity. Avoid exposing the broker's management interfaces to untrusted networks. Follow any additional guidance from Apache Software Foundation advisories once published.

Description

Improper Input Validation, Improper Control of Generation of Code ('Code Injection') vulnerability in Apache ActiveMQ Broker, Apache ActiveMQ All, Apache ActiveMQ. Apache ActiveMQ Classic exposes the Jolokia JMX-HTTP bridge at /api/jolokia/ on the web console. The default Jolokia access policy permits exec operations on all ActiveMQ MBeans (org.apache.activemq:*), including BrokerService.addNetworkConnector(String). An authenticated attacker can invoke these operations with a crafted discovery URI that triggers the VM transport's brokerConfig parameter using the "masterslave:// " URL which can allow loading a Spring XML application context using ResourceXmlApplicationContext. Because Spring's ResourceXmlApplicationContext instantiates all singleton beans before the BrokerService validates the configuration, arbitrary code execution occurs on the broker's JVM through bean factory methods such as Runtime.exec(). This issue affects Apache ActiveMQ Broker: before 5.19.7, from 6.0.0 before 6.2.6; Apache ActiveMQ All: before 5.19.7, from 6.0.0 before 6.2.6; Apache ActiveMQ: before 5.19.7, from 6.0.0 before 6.2.6. Users are recommended to upgrade to version 5.19.7 or 6.2.6, which fixes the issue.

References

Community reviews

Loading reviews…