CVE-2026-42613: getgrav grav · Improper Input Validation
Affects getgrav gravSource CVE Database V5
Not known to be exploited · CVSS 9.4 Critical : upgrade to 2.0.0-beta.2 as a priority.
Data as of 30 Oct 2026, 06:59 UTC
- EPSS
- 1.1% chance of exploitation in 30 days – higher than 66% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.0.0-beta.2
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:LExploitation evidence
Disclosed: evidence found.
CVE published 11 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: evidence found.
Public exploit code: GitHub proofs of concept
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), GitHub proofs of concept, the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade getgrav grav to 2.0.0-beta.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| getgravgrav | Affected
| Fixed in
|
GitHubgetgrav/gravpkg:github/getgrav/gravOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade Grav to version 2.0.0-beta.2 or later, where this vulnerability is fixed. Until upgraded, disable user registration or ensure that 'groups' and 'access' fields are not included in the allowed registration fields list to mitigate risk.
Description
A critical vulnerability (CVE-2026-42613) exists in the Grav CMS prior to version 2.0.0-beta.2. The Login plugin's register() method improperly validates input fields from unauthenticated registration POST requests, allowing an attacker to self-register with admin.super privileges by injecting groups or access fields when registration is enabled and these fields are allowed. This vulnerability is fixed in version 2.0.0-beta.2.