Skip to main content
VulnerabilityPublished Updated

CVE-2026-42794: absinthe_plug · Cross-site Scripting

Affects absinthe_plugSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 2.3 Low : upgrade to 1.5.10 when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
2.3Low
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 20% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.5.10, 23a0d5658d32420086711adf4ce8f05febb09963
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 8 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade absinthe_plug to 1.5.10; absinthe_plug to 23a0d5658d32420086711adf4ce8f05febb09963.

Affected software

ProductAffectedFixed in
absinthe-graphqlabsinthe_plugAffected
  • >=1.2.0 <1.5.10
Fixed in
  • 1.5.10
absinthe-graphqlabsinthe_plugAffected
  • ≥ 26241817cb4b9be4de3f5972c5fba3d36de3d713, < 23a0d5658d32420086711adf4ce8f05febb09963
Fixed in
  • 23a0d5658d32420086711adf4ce8f05febb09963
Hexabsinthe_plugpkg:hex/absinthe_plugOther threatsAffected
  • >=1.2.0 <1.5.10
Fixed in
  • 1.5.10

CPE configurations (1)

  • cpe:2.3:a:absinthe-graphql:absinthe_plug:*:*:*:*:*:*:*:*

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

If you cannot patch yet, consider restricting access to the GraphiQL interface or implementing web application firewall (WAF) rules to detect and block suspicious query parameters that may exploit this XSS vulnerability.

Description

Improper Neutralization of Input During Web Page Generation (XSS) vulnerability in absinthe-graphql absinthe_plug allows reflected cross-site scripting via the GraphiQL interface. 'Elixir.Absinthe.Plug.GraphiQL':js_escape/1 in lib/absinthe/plug/graphiql.ex escapes single quotes and newlines in the query GET parameter before embedding it in an inline JavaScript string, but does not escape backslashes. An attacker can bypass the escaping by prefixing a quote with a backslash (e.g. \'), breaking out of the string context and executing arbitrary JavaScript in the victim's browser. This issue affects absinthe_plug: from 1.2.0 before 1.5.10.

References

Community reviews

Loading reviews…