Skip to main content
VulnerabilityPublished Updated

CVE-2026-42847: MacWarrior clipbucket-v5 · SQL Injection

Affects MacWarrior clipbucket-v5Source CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.1 High : upgrade to 5.5.3 soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
7.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 16% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 5.5.3
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 14 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade macwarrior/clipbucket-v5 to 5.5.3.

Affected software

ProductAffectedFixed in
MacWarriorclipbucket-v5Affected
  • =< 5.5.3 - #122
Fixed in–
GitHubmacwarrior/clipbucket-v5pkg:github/macwarrior/clipbucket-v5Other threatsAffected
  • <5.5.3
Fixed in
  • 5.5.3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade ClipBucket to version 5.5.3 or later, where this SQL Injection vulnerability is fixed. Since the vendor advisory confirms the fix in 5.5.3, applying this official patch is the recommended remediation. No other mitigation guidance is provided or necessary based on the available information.

Description

ClipBucket v5 versions prior to 5.5.3 contain a critical SQL Injection vulnerability in the authenticated admin endpoint admin_area/action_logs.php. The vulnerability arises because the 'type' parameter from the GET request is directly concatenated into a SQL query without proper parameterization, allowing an attacker with admin privileges to perform UNION-based SQL injection and potentially exfiltrate database data. This issue is fixed in version 5.5.3.

References

Community reviews

Loading reviews…