CVE-2026-42849: goauthentik authentik · Cross-site Scripting
Affects goauthentik authentikSource CVE Database V5
Not known to be exploited · CVSS 9.3 Critical : upgrade to 2026.2.3 or 2025.12.5 as a priority.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 25% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2026.2.3, 2025.12.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 2 Jun 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade authentik and github.com/goauthentik/authentik to 2026.2.3 or 2025.12.5.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| goauthentikauthentik | Affected
| Fixed in
|
| goauthentikauthentik | Affected
| Fixed in
|
Gogithub.com/goauthentik/authentikpkg:golang/github.com/goauthentik/authentikOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
This vulnerability has been patched in authentik versions 2025.12.5 and 2026.2.3. Users should upgrade to at least one of these versions to remediate the issue. No additional mitigation steps are indicated by the vendor advisory.
Description
authentik is an open-source identity provider. Prior to versions 2025.12.5 and 2026.2.3, due to the implementation of stages in the SFE (Simple Flow Executor) in order to make the interface more compatible with legacy browsers, it was possible to use an XSS exploit in the AutosubmitStage. This issue has been patched in versions 2025.12.5 and 2026.2.3.