Skip to main content
VulnerabilityPublished Updated

CVE-2026-42851: kovidgoyal kitty · Code Injection

Affects kovidgoyal kittySource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.8 High : upgrade to 0.47.0 soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
7.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 5% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.47.0
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 12 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade kitty and kovidgoyal/kitty to 0.47.0.

Affected software

ProductAffectedFixed in
kovidgoyalkittyAffected
  • <0.47.0
Fixed in
  • 0.47.0
GitHubkovidgoyal/kittypkg:github/kovidgoyal/kittyOther threatsAffected
  • <0.47.0
Fixed in
  • 0.47.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade kitty to version 0.47.0 or later, which fixes this vulnerability. Patch status is confirmed by the vendor's versioning information. No additional mitigation is required once the update is applied.

Description

Kitty is a cross-platform GPU based terminal. In versions prior to 0.47.0, a program able to write bytes to a kitty terminal — a remote SSH peer, a downloaded file viewed with `cat`, a log line, an email body rendered in `less`, an issue body in a TUI, etc. — can cause kitty to execute attacker-supplied Python inside the running kitty process, with the user's full privileges. There is no approval prompt, no remote-control permission requirement, no shell-integration interaction, no clipboard touch, and no editor interaction. Version 0.47.0 fixes the issue.

References

Community reviews

Loading reviews…