Skip to main content
VulnerabilityPublished

CVE-2026-42867: langflow · Path Traversal

Affects langflowSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.5 Medium : upgrade to 1.9.0 when convenient.

Data as of 6 Nov 2026, 23:24 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 40% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.9.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 23 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.

What to do

Upgrade langflow and langflow-ai/langflow to 1.9.0.

Affected software

ProductAffectedFixed in
langflow-ailangflowAffected
  • <1.9.0
Fixed in
  • 1.9.0
GitHublangflow-ai/langflowpkg:github/langflow-ai/langflowOther threatsAffected
  • <1.9.0
Fixed in
  • 1.9.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade langflow to version 1.9.0 or later, where this path traversal vulnerability is fixed. No other mitigation or temporary workaround is indicated. Since this is not a cloud service, remediation depends on applying the official fix.

Description

Langflow is a tool for building and deploying AI-powered agents and workflows. Prior to 1.9.0, Langflow is vulnerable to Path Traversal in the Knowledge Bases API (POST /api/v1/knowledge_bases). This occurs because user-supplied knowledge base names are used directly to create file paths without proper sanitization or containment checks. An authenticated attacker can exploit this flaw to create directories and write files anywhere on the server's filesystem. This vulnerability is fixed in 1.9.0.

References

Community reviews

Loading reviews…