CVE-2026-33309: langflow · Path Traversal
Affects langflowSource CVE Database V5
Mentioned vulnerabilities
Not known to be exploited · 13% EPSS · CVSS 10.0 Critical : upgrade to 1.9.0 as a priority.
Data as of 29 Oct 2026, 19:04 UTC
- EPSS
- 13.4% chance of exploitation in 30 days – higher than 96% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.9.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 24 Mar 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade langflow to 1.9.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| langflow-ailangflow | Affected
| Fixed in
|
PyPIlangflowpkg:pypi/langflowOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
- Immediate upgrade to langflow version 1.9.0 or later, which contains the updated fix addressing the architectural flaw.
- Restrict access to the POST /api/v2/files/ endpoint to trusted users and networks only, employing network segmentation and firewall rules.
- Implement strong authentication and authorization controls to limit who can access the vulnerable endpoint.
- Monitor file system changes and application logs for unusual file write activities, especially in directories outside expected storage paths.
- Employ runtime application self-protection (RASP) or host-based intrusion detection systems (HIDS) to detect and block suspicious file operations.
- Conduct regular security audits and code reviews focusing on input validation and boundary checks in storage components.
- If immediate upgrade is not possible, consider temporarily disabling the file upload functionality or applying custom patches to enforce boundary checks.
- Educate developers and administrators about the importance of defense-in-depth and not relying solely on HTTP-layer validation for critical security controls.
Description
CVE-2026-33309 is a critical path traversal vulnerability in langflow versions 1.2.0 through 1.8.1. It arises from an architectural flaw in the LocalStorageService where boundary checks are missing, allowing an authenticated attacker to bypass filename validation on the POST /api/v2/files/ endpoint. This enables arbitrary file write anywhere on the host system, potentially leading to remote code execution without user interaction. The vulnerability stems from a failed patch for a previous related issue (CVE-2025-68478) and is fixed in version 1.9.0.