Skip to main content
VulnerabilityPublished

CVE-2026-42926: F5 NGINX Open Source · Encoding Error

Affects F5 NGINX Open SourceSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 5.8 Medium : upgrade to 1.30.1 when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
5.8Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 28% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.30.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    Public exploit code: GitHub proofs of concept

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), GitHub proofs of concept, the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade F5 NGINX Open Source to 1.30.1.

Affected software

ProductAffectedFixed in
F5NGINX Open SourceAffected
  • >=1.29.4 <1.30.1
Fixed in
  • 1.30.1

AI-suggested

If you cannot patch yet, users should review their proxy_http_version and proxy_set_body configurations to assess exposure. No vendor-provided mitigation or temporary fix is currently available.

Description

When NGINX Open Source is configured to proxy HTTP/2 traffic by setting proxy_http_version to 2, and also uses proxy_set_body, an attacker may be able to inject frame headers and payload bytes to the upstream peer. Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated.

References

Community reviews

Loading reviews…