Skip to main content
VulnerabilityPublished Updated

CVE-2026-43870: Apache Thrift · Origin Validation Error

Affects Apache ThriftSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.3 High : upgrade to 0.23.0 soon.

Data as of 1 Nov 2026, 22:58 UTC

CVSS 3.1 base score
7.3High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 31% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.23.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 5 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 1 Nov 2026.

What to do

Upgrade Apache Thrift and org.apache.thrift/thrift to 0.23.0.

Affected software

ProductAffectedFixed in
Apache Software FoundationApache ThriftAffected
  • <0.23.0
Fixed in
  • 0.23.0
Mavenorg.apache.thrift/thriftpkg:maven/org.apache.thrift/thriftOther threatsAffected
  • <0.23.0
Fixed in
  • 0.23.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade Apache Thrift to version 0.23.0, which contains fixes for these vulnerabilities. No other official remediation or temporary fixes are indicated. Patch status is confirmed by the vendor advisory recommending this upgrade.

Description

CVE-2026-43870 is a high-severity vulnerability in Apache Thrift before version 0.23.0 involving multiple security weaknesses: origin validation errors (CWE-346), path traversal (CWE-22), HTTP request/response splitting (CWE-113), and uncontrolled resource consumption (CWE-400). These issues can lead to limited confidentiality, integrity, and availability impacts. The Apache Software Foundation recommends upgrading to version 0.23.0 to address these vulnerabilities.

References

Community reviews

Loading reviews…