Skip to main content
VulnerabilityPublished

CVE-2026-43893: photostructure exiftool-vendored.js · Argument Injection

Affects photostructure exiftool-vendored.jsSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.2 High : upgrade to 35.19.0 soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
8.2High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 41% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 35.19.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 11 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    Public exploit code: GitHub proofs of concept

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), GitHub proofs of concept, the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade photostructure exiftool-vendored.js to 35.19.0.

Affected software

ProductAffectedFixed in
photostructureexiftool-vendored.jsAffected
  • <35.19.0
Fixed in
  • 35.19.0
npmexiftool-vendored.jspkg:npm/exiftool-vendored.jsOther threatsAffected
  • <35.19.0
Fixed in
  • 35.19.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

This vulnerability is fixed in exiftool-vendored.js version 35.19.0. Users should upgrade to version 35.19.0 or later to remediate this issue. Patch status is not explicitly stated beyond the fixed version; therefore, confirm remediation by upgrading to the fixed version. No other vendor advisory or temporary workaround is provided.

Description

A high-severity vulnerability (CVE-2026-43893) exists in photostructure's exiftool-vendored.js prior to version 35.19.0. The issue involves improper neutralization of argument delimiters, allowing attacker-controlled input containing newline or carriage return characters to inject additional arguments into ExifTool commands. This can cause ExifTool to read or write files accessible to its process based on attacker input. No remote code execution has been demonstrated. The vulnerability is fixed in version 35.19.0.

References

Community reviews

Loading reviews…