CVE-2026-43897: OP-Engineering link-preview-js · Server-Side Request Forgery (SSRF)
Affects OP-Engineering link-preview-jsSource CVE Database V5
Not known to be exploited · CVSS 8.7 High : upgrade to 4.0.1 soon.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.6% chance of exploitation in 30 days – higher than 51% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 4.0.1
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 11 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade OP-Engineering link-preview-js to 4.0.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| OP-Engineeringlink-preview-js | Affected
| Fixed in
|
npmlink-preview-jspkg:npm/link-preview-jsOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
This vulnerability is fixed in link-preview-js version 4.0.1. Users of the library should upgrade to version 4.0.1 or later to remediate this issue. No additional mitigation guidance is provided or required beyond applying this update. Patch status is confirmed fixed in version 4.0.1.
Description
CVE-2026-43897 is a high-severity Server-Side Request Forgery (SSRF) vulnerability in the OP-Engineering link-preview-js library versions prior to 4.0.1. The vulnerability arises because the library did not properly validate IPv6 loopback addresses and was susceptible to DNS attacks that could resolve addresses to internal IPs. This flaw could lead to internal data leaks by allowing unauthorized access to internal network resources. The issue is fixed in version 4.0.1 of the library.
References
- github.com/OP-Engineering/link-preview-js/security/advisories/GHSA-4gp8-rjrq-ch6q (opens in a new tab)
- github.com/OP-Engineering/link-preview-js/pull/179 (opens in a new tab)
- github.com/OP-Engineering/link-preview-js/commit/4396d48909fab37553c0e93e26447fe218363ede (opens in a new tab)
- github.com/OP-Engineering/link-preview-js/releases/tag/4.0.1 (opens in a new tab)