CVE-2026-43899: ThinkInAIXYZ deepchat · Improper Input Validation
Affects ThinkInAIXYZ deepchatSource CVE Database V5
Mentioned vulnerabilities
Not known to be exploited · CVSS 9.6 Critical : upgrade to 1.0.4-beta.1 as a priority.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 34% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.0.4-beta.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 11 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade ThinkInAIXYZ deepchat to 1.0.4-beta.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| ThinkInAIXYZdeepchat | Affected
| Fixed in
|
GitHubthinkinaixyz/deepchatpkg:github/thinkinaixyz/deepchatOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade DeepChat to version 1.0.4-beta.1 or later, where this vulnerability is fixed. Since the vendor advisory confirms the fix in this version, applying this update fully mitigates the risk. There is no indication of partial or temporary fixes, and no alternative mitigations are provided. Patch status is confirmed by the vendor's versioning information.
Description
CVE-2026-43899 is a critical vulnerability in ThinkInAIXYZ's DeepChat platform prior to version 1.0.4-beta.1. It involves improper input validation that allows an attacker or compromised AI endpoint to bypass security restrictions and execute arbitrary protocols via Electron's native pop-up window handlers. Specifically, malicious Markdown links with target="_blank" can trigger shell.openExternal(url) calls without proper URL validation, leading to remote code execution. This issue was introduced due to an incomplete mitigation of a previous vulnerability (CVE-2025-55733). The vulnerability is fixed in DeepChat version 1.0.