CVE-2026-43951: Apache HTTP Server · Out-of-bounds Read
Affects Apache HTTP ServerSource CVE Database V5
Not known to be exploited · CVSS 6.5 Medium : upgrade to 2.4.68 when convenient.
Data as of 29 Oct 2026, 19:04 UTC
- EPSS
- 0.5% chance of exploitation in 30 days – higher than 45% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.4.68
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 8 Jun 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade apache/httpd to 2.4.68.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Apache Software FoundationApache HTTP Server | Affected
| Fixed in– |
Apacheapache/httpdpkg:rpm/apache/httpdOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
Description
An out-of-bounds read vulnerability (CWE-125) exists in Apache HTTP Server versions from 2.4.0 through 2.4.67 when using mod_headers and mod_mime with multiple response languages. This flaw could allow an attacker to read memory outside the intended buffer. The vulnerability has a CVSS 3.1 base score of 6.5, indicating a medium severity level. There are no known exploits in the wild at this time.