CVE-2026-43999: patriksimek vm2 · Incorrect Authorization
Affects patriksimek vm2Source CVE Database V5
Not known to be exploited · CVSS 9.9 Critical : upgrade to 3.11.0 as a priority.
Data as of 29 Oct 2026, 19:04 UTC
- EPSS
- 0.9% chance of exploitation in 30 days – higher than 61% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.11.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 13 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade patriksimek vm2 to 3.11.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| patriksimekvm2 | Affected
| Fixed in
|
npmvm2pkg:npm/vm2Other threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in vm2 version 3.11.0. Users should upgrade to vm2 3.11.0 or later to remediate this vulnerability. Until upgraded, avoid allowing the builtin module or the '*' wildcard in the NodeVM builtin allowlist to reduce exposure. The vendor advisory does not mention any other mitigations or temporary fixes.
Description
vm2 is an open source vm/sandbox for Node.js. Prior to 3.11.0, NodeVM's builtin allowlist can be bypassed when the module builtin is allowed (including via the '*' wildcard). The module builtin exposes Node's Module._load(), which loads any module by name directly in the host context, completely bypassing vm2's builtin restriction. This allows sandboxed code to load excluded builtins like child_process and achieve remote code execution. This vulnerability is fixed in 3.11.0.
References
- github.com/patriksimek/vm2/security/advisories/GHSA-947f-4v7f-x2v8 (opens in a new tab)
- access.redhat.com/security/cve/CVE-2026-43999 (opens in a new tab)
- bugzilla.redhat.com/show_bug.cgi?id=2477196 (opens in a new tab)
- security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-43999.json (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:50850 (opens in a new tab)