Skip to main content
VulnerabilityPublished

CVE-2026-4416: GIGABYTE Performance Library · Deserialization of Untrusted Data

Affects GIGABYTE Performance LibrarySource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.5 High : upgrade to 25.12.31.01 soon.

Data as of 29 Oct 2026, 19:04 UTC

CVSS 4.0 base score
8.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 10% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 25.12.31.01
CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade GIGABYTE Performance Library to 25.12.31.01.

Affected software

ProductAffectedFixed in
GIGABYTEPerformance LibraryAffected
  • <25.12.31.01
Fixed in
  • 25.12.31.01

AI-suggested

If you cannot patch yet, restrict local access to trusted users only and monitor for suspicious activity related to the EasyTune Engine service. Avoid running the affected software with elevated privileges where possible.

Description

CVE-2026-4416 is a high-severity vulnerability in the Performance Library component of the Gigabyte Control Center. It involves insecure deserialization of untrusted data, allowing authenticated local attackers to send malicious serialized payloads to the EasyTune Engine service. Successful exploitation can lead to privilege escalation on the affected system. There is no information about an available patch or vendor advisory at this time. The vulnerability requires local authentication and does not involve user interaction.

References

Community reviews

Loading reviews…