Skip to main content
VulnerabilityPublished

CVE-2026-44171: MariaDB server · Path Traversal

Affects MariaDB serverSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.3 Medium · fixed in 12.3.2 : update MariaDB server when convenient.

Data as of 29 Oct 2026, 19:04 UTC

CVSS 3.1 base score
6.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 8% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 12.3.2, 11.8.7, 11.4.11 +2
CVSS:3.1/AV:L/AC:H/PR:H/UI:R/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 12 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
MariaDBserverAffected
  • >=12.3.1 <12.3.2
Fixed in
  • 12.3.2
MariaDBserverAffected
  • >=11.8.1 <11.8.7
Fixed in
  • 11.8.7
MariaDBserverAffected
  • >=11.4.1 <11.4.11
Fixed in
  • 11.4.11
MariaDBserverAffected
  • >=10.11.1 <10.11.17
Fixed in
  • 10.11.17
MariaDBserverAffected
  • >=10.6.1 <10.6.26
Fixed in
  • 10.6.26
GitHubmariadb/serverpkg:github/mariadb/serverOther threatsAffected
  • >=10.6.1 <10.6.26
  • 10.11.1 <10.11.17
  • 11.4.1 <11.4.11
  • 11.8.1 <11.8.7
  • =12.3.1
Fixed in
  • 10.6.26
  • 10.11.17
  • 11.4.11
  • 11.8.7

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in MariaDB server versions 10.6.26, 10.11.17, 11.4.11, 11.8.7, and 12.3.2. Users should upgrade to these or later versions to remediate the vulnerability. No vendor advisory content contradicts this; therefore, upgrading is the recommended mitigation.

Description

A path traversal vulnerability (CWE-22) exists in the mbstream component of MariaDB server versions 10.6.1 to before 10.6.26, 10.11.1 to before 10.11.17, 11.4.1 to before 11.4.11, 11.8.1 to before 11.8.7, and exactly 12.3.1. The vulnerability allows specially crafted archives containing '/../' sequences to cause mbstream to write files outside the intended target directory during archive unpacking. This issue has been addressed in MariaDB server versions 10.6.26, 10.11.17, 11.4.11, 11.8.7, and 12.3.2.

References

Community reviews

Loading reviews…