Skip to main content
VulnerabilityPublished Updated

CVE-2026-44185: Apache HTTP Server · Buffer Over-read

Affects Apache HTTP ServerSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.3 High · fixed in 2.4.68 : patch Apache HTTP Server soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
7.3High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.7% chance of exploitation in 30 days – higher than 54% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.4.68
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 8 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
Apache Software FoundationApache HTTP ServerAffected
  • >=2.4.0 <=2.4.67
Fixed in–

AI-suggested

A fix is available in Apache HTTP Server version 2.4.68; users should upgrade to this version to remediate the vulnerability. Alternatively, if OCSP validation or stapling is not critical, administrators can mitigate the risk by configuring Apache HTTP Server to disable OCSP and stapling via mod_ssl directives: set SSLOCSPEnable off and SSLUseStapling off, then reload the httpd service. It is also recommended to ensure that OCSP responders are trusted endpoints to reduce exposure.

Description

Buffer Over-read vulnerability in Apache HTTP Server via outbound OCSP requests to an attacker controlled OCSP server This issue affects Apache HTTP Server: from 2.4.0 through 2.4.67. Users are recommended to upgrade to version 2.4.68, which fixes the issue.

References

Community reviews

Loading reviews…