Skip to main content
VulnerabilityPublished

CVE-2026-44186: Apache HTTP Server · Infinite Loop

Affects Apache HTTP ServerSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.3 High · fixed in 2.4.68 : patch Apache HTTP Server soon.

Data as of 29 Oct 2026, 19:04 UTC

CVSS 3.1 base score
7.3High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 47% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.4.68
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 8 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
Apache Software FoundationApache HTTP ServerAffected
  • >=2.4.0 <=2.4.67
Fixed in–

AI-suggested

Users should upgrade Apache HTTP Server to version 2.4.68 or later to remediate this vulnerability. Patch status is confirmed by the version upgrade recommendation. No other mitigations are specified.

Description

CVE-2026-44186 is a high-severity vulnerability in the Apache HTTP Server's mod_proxy_ftp module that causes an infinite loop due to an unreachable exit condition. This affects versions from 2.4.0 through 2.4.67. The vulnerability can be triggered by an attacker-controlled backend FTP server. Users are advised to upgrade to version 2.4.68, which addresses this issue.

References

Community reviews

Loading reviews…