CVE-2026-44232: HackingRepo dssrf-js · Incomplete Filtering of Special Elements
Affects HackingRepo dssrf-jsSource CVE Database V5
Not known to be exploited · CVSS 8.7 High : upgrade to 1.0.3 soon.
Data as of 29 Oct 2026, 19:04 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 35% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.0.3, 1.3.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 12 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade dssrf-js to 1.0.3; dssrf-js to 1.3.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| HackingRepodssrf-js | Affected
| Fixed in
|
npmdssrf-jspkg:npm/dssrf-jsOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade dssrf-js to version 1.0.3 or later to apply the official fix for this vulnerability. Versions prior to 1.0.3 are affected. No other mitigation or temporary workaround is indicated in the available data.
Description
DSSRF is a Node.js library that provides a wide range of utilities and advanced SSRF defense checks. Prior to 1.0.3, every IPv6 category bypasses is_url_safe. This vulnerability is fixed in 1.0.3.