Skip to main content
VulnerabilityPublished Updated

CVE-2026-4428: AWS-LC · Improper Check for Certificate Revocation

Affects AWS-LCSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.4 High : upgrade to 1.71.0 soon.

Data as of 31 Oct 2026, 20:20 UTC

CVSS 3.1 base score
7.4High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 17% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.71.0, 3.3.0
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 19 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 31 Oct 2026.

What to do

Upgrade AWS-LC to 1.71.0; AWS-LC-FIPS to 3.3.0.

Affected software

ProductAffectedFixed in
AWSAWS-LCAffected
  • >=1.24.0 <1.71.0
Fixed in
  • 1.71.0
AWSAWS-LC-FIPSAffected
  • >=3.0.0 <3.3.0
Fixed in
  • 3.3.0
GitHubaws/aws-lcpkg:github/aws/aws-lcOther threatsAffected
  • <=1.24.0
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade to AWS-LC version 1.71.0 or AWS-LC-FIPS-3.3.0 to remediate this issue. No other mitigations are indicated by the vendor advisory.

Description

CVE-2026-4428 is a logic error in AWS-LC versions before 1.71.0 that causes partitioned Certificate Revocation Lists (CRLs) to be incorrectly rejected as out of scope. This flaw allows revoked certificates to bypass revocation checks, potentially enabling use of invalid certificates. The issue is fixed by upgrading to AWS-LC 1.71.0 or AWS-LC-FIPS-3.3.0.

References

Community reviews

Loading reviews…