CVE-2026-44444: prolix-oc Lumiverse · OS Command Injection
Affects prolix-oc LumiverseSource CVE Database V5
Not known to be exploited · CVSS 9.1 Critical : upgrade to 0.9.7 as a priority.
Data as of 30 Oct 2026, 06:59 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 30% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 0.9.7
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 26 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade Lumiverse and prolix-oc/Lumiverse to 0.9.7.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| prolix-ocLumiverse | Affected
| Fixed in
|
GitHubprolix-oc/Lumiversepkg:github/prolix-oc/LumiverseOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade Lumiverse to version 0.9.7 or later, where this vulnerability is fixed by adding the --ignore-scripts flag to the 'bun install' command in the Spindle extension build pipeline. Until upgraded, avoid installing untrusted extensions and review extension package.json files for malicious lifecycle scripts before installation. Patch status is confirmed fixed in version 0.9.7.
Description
CVE-2026-44444 is a critical OS command injection vulnerability in prolix-oc Lumiverse versions prior to 0.9.7. The issue arises because the Spindle extension build pipeline runs 'bun install' without the --ignore-scripts flag before performing a backend safety scan. This allows a malicious extension with lifecycle scripts (preinstall, postinstall, or prepare) in its package.json to execute arbitrary code on the host when an admin installs the extension. The vulnerability is fixed in version 0.9.7.