Skip to main content
VulnerabilityPublished Updated

CVE-2026-44578: vercel next.js · Server-Side Request Forgery (SSRF)

Affects vercel next.jsSource CVE Database V5

0
Compare

Not known to be exploited · public detection template (Nuclei) · 35% EPSS · CVSS 8.6 High : upgrade to 16.2.5 or 15.5.16 soon.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 3.1 base score
8.6High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
35.5% chance of exploitation in 30 days – higher than 98% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 16.2.5, 15.5.16, 16.2
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 May 2026

  2. Weaponized: evidence found.

    Public exploit code: GitHub proofs of concept

  3. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  4. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), GitHub proofs of concept, the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade next.js to 16.2.5 or 15.5.16; next to 16.2 or 15.5.16.

Affected software

ProductAffectedFixed in
vercelnext.jsAffected
  • >=16.0.0 <16.2.5
Fixed in
  • 16.2.5
vercelnext.jsAffected
  • >=13.4.13 <15.5.16
Fixed in
  • 15.5.16
npmnextpkg:npm/nextOther threatsAffected
  • >=13.4.13 <15.5.16
  • >=16.0.0 <16.2
Fixed in
  • 15.5.16
  • 16.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

The vulnerability is fixed in Next.js versions 15.5.16 and 16.2.5. Users of affected versions should upgrade to these fixed versions to remediate the issue. Red Hat advisories indicate that no effective mitigation other than upgrading currently meets their criteria. Vercel-hosted deployments are not affected and require no action. Check the vendor advisory for the latest remediation guidance.

Description

Next.js is a React framework for building full-stack web applications. From 13.4.13 to before 15.5.16 and 16.2.5, self-hosted applications using the built-in Node.js server can be vulnerable to server-side request forgery through crafted WebSocket upgrade requests. An attacker can cause the server to proxy requests to arbitrary internal or external destinations, which may expose internal services or cloud metadata endpoints. Vercel-hosted deployments are not affected. This vulnerability is fixed in 15.5.16 and 16.2.5.

References

Community reviews

Loading reviews…