Skip to main content
VulnerabilityPublished Updated

CVE-2026-44582: vercel next.js · Use of Weak Hash

Affects vercel next.jsSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 3.7 Low : upgrade to 16.2.5 or 15.5.16 when convenient.

Data as of 29 Oct 2026, 19:04 UTC

CVSS 3.1 base score
3.7Low
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 11% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 16.2.5, 15.5.16
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade next.js and next to 16.2.5 or 15.5.16.

Affected software

ProductAffectedFixed in
vercelnext.jsAffected
  • >=16.0.0 <16.2.5
Fixed in
  • 16.2.5
vercelnext.jsAffected
  • >=13.4.6 <15.5.16
Fixed in
  • 15.5.16
npmnextpkg:npm/nextOther threatsAffected
  • >=13.4.6 <15.5.16
  • <16.2.5
Fixed in
  • 15.5.16
  • 16.2.5

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

The vulnerability is fixed in Next.js versions 15.5.16 and 16.2.5. Users should upgrade to these or later versions to remediate the issue. Patch status is not explicitly confirmed in the vendor advisory content provided, but the description states the issue is fixed in these versions. No additional mitigation steps are indicated.

Description

Next.js is a React framework for building full-stack web applications. From 13.4.6 to before 15.5.16 and 16.2.5, React Server Component responses can be vulnerable to cache poisoning in deployments that rely on shared caches with insufficient response partitioning. In affected conditions, collisions in the _rsc cache-busting value can allow an attacker to poison cache entries so users receive the wrong response variant for a given URL. This vulnerability is fixed in 15.5.16 and 16.2.5.

References

Community reviews

Loading reviews…