Skip to main content
VulnerabilityPublished Updated

CVE-2026-44616: Apache Zeppelin · LDAP Injection

Affects Apache ZeppelinSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.5 Medium : upgrade to 0.12.1 when convenient.

Data as of 29 Oct 2026, 07:15 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.7% chance of exploitation in 30 days – higher than 55% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.12.1
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade Apache Zeppelin to 0.12.1.

Affected software

ProductAffectedFixed in
Apache Software FoundationApache ZeppelinAffected
  • >=0.6.0 <0.12.1
Fixed in
  • 0.12.1
Mavenorg.apache.zeppelin/zeppelinpkg:maven/org.apache.zeppelin/zeppelinOther threatsAffected
  • =0.6.0
  • <=0.12.0
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade Apache Zeppelin to version 0.12.1 or later, which addresses this LDAP injection vulnerability. No other mitigations or temporary fixes are indicated. Patch status is confirmed by the vendor advisory recommending the upgrade to 0.12.1.

Description

Apache Zeppelin versions 0.6.0 through 0.12.0 contain an LDAP injection vulnerability in the ActiveDirectoryGroupRealm component. This flaw allows an authenticated attacker to inject LDAP filter syntax via the user-search endpoint and potentially expose directory information. The role-lookup path is also affected after successful LDAP authentication. The issue is fixed in version 0.12.1.

References

Community reviews

Loading reviews…