CVE-2026-44691: Eclipse Theia · Untrusted Functionality Inclusion
Affects Eclipse TheiaSource CVE Database V5
Not known to be exploited · CVSS 8.4 High : upgrade to 1.69.0 soon.
Data as of 1 Nov 2026, 08:20 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 35% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.69.0
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 18 Jun 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 31 Oct 2026.
What to do
Upgrade Eclipse Theia to 1.69.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Eclipse FoundationEclipse Theia | Affected
| Fixed in
|
GitHubEclipse Theiapkg:github/Eclipse TheiaOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
If you cannot patch yet, users should avoid opening untrusted repositories in Eclipse Theia versions prior to 1.69.0. Additionally, review and adjust workspace settings to ensure tool confirmation is enabled, especially when using AI chat features, to prevent automatic execution of tasks from untrusted sources.
Description
Eclipse Theia versions prior to 1.69.0 allow execution of custom task definitions from workspace files without requiring workspace trust. This vulnerability enables an attacker to craft a malicious repository that, when opened in Theia, executes arbitrary commands with the user's privileges. The issue can be exacerbated by AI chat features combined with workspace settings that disable tool confirmation, potentially triggering automatic execution. The vulnerability is identified as CWE-829 and has a high severity with a CVSS score of 8.4.