CVE-2026-44740: go-git go-billy · Uncontrolled Recursion
Affects go-git go-billySource CVE Database V5
Not known to be exploited · CVSS 6.5 Medium : upgrade to 6.0.0-alpha.1 or 5.9.0 when convenient.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 32% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 6.0.0-alpha.1, 5.9.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 1 Jun 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade go-billy to 6.0.0-alpha.1 or 5.9.0; github.com/go-git/go-billy to 5.9.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| go-gitgo-billy | Affected
| Fixed in
|
| go-gitgo-billy | Affected
| Fixed in
|
Gogithub.com/go-git/go-billypkg:golang/github.com/go-git/go-billyOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in go-billy versions 5.9.0 and 6.0.0-alpha.1. Users should upgrade to these versions or later to remediate the vulnerability. No vendor advisory is provided to indicate alternative mitigations or temporary fixes. Patch status is not explicitly confirmed beyond the stated fixed versions; users should verify with the official go-git/go-billy project resources for the latest remediation guidance.
Description
The go-billy filesystem abstraction for Go prior to version 5.9.0 and including 6.0.0-alpha.1 contains vulnerabilities related to uncontrolled recursion and improper handling of malformed input. These issues can cause panics, infinite loops, or excessive resource consumption due to missing safety mechanisms like cycle detection and recursion limits. The vulnerability has been addressed in versions 5.9.0 and 6.0.0-alpha.1.