Skip to main content
VulnerabilityPublished Updated

CVE-2026-44832: grokability snipe-it · Improper Preservation of Permissions

Affects grokability snipe-itSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.7 High : upgrade to 8.4.1 soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
8.7High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 24% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 8.4.1
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 26 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade snipe-it and grokability/snipe-it to 8.4.1.

Affected software

ProductAffectedFixed in
grokabilitysnipe-itAffected
  • <8.4.1
Fixed in
  • 8.4.1
GitHubgrokability/snipe-itpkg:github/grokability/snipe-itOther threatsAffected
  • <8.4.1
Fixed in
  • 8.4.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Snipe-IT to version 8.4.1 or later, where this vulnerability is fixed. No other official remediation or temporary fixes are documented. Patch status is confirmed fixed in 8.4.1.

Description

Snipe-IT is an IT asset/license management system. Prior to 8.4.1, aAn authenticated user with only users.edit permission can escalate their own privileges to admin by sending a PATCH request to /api/v1/users/{id} with permissions[admin]=1. The API controller only strips the superuser key from the permissions array, allowing admin and all other permission keys to be set by any user who can update users. This vulnerability is fixed in 8.4.1.

References

Community reviews

Loading reviews…