CVE-2026-44983: servo smallbitvec · Heap-based Buffer Overflow
Affects servo smallbitvecSource CVE Database V5
Not known to be exploited · CVSS 7.3 High : upgrade to 2.6.1 soon.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 4% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.6.1
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:HExploitation evidence
Disclosed: evidence found.
CVE published 26 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade smallbitvec and github/servo/smallbitvec to 2.6.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| servosmallbitvec | Affected
| Fixed in
|
crates.iogithub/servo/smallbitvecpkg:cargo/github/servo/smallbitvecOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade 'smallbitvec' to version 2.6.1 or later, where this vulnerability is fixed. Since this is a library vulnerability, users should update their dependencies accordingly. No vendor advisory is provided to indicate alternative mitigations or temporary fixes. Patch status is confirmed by the version fix information in the description.
Description
smallbitvec is a growable bit-vector for Rust, optimized for size. From 1.0.1 to 2.6.0, an integer overflow in the internal capacity calculation of smallbitvec can lead to an undersized heap allocation, resulting in a heap buffer overflow through safe APIs only. This allows memory corruption without requiring unsafe code from the caller. This vulnerability is fixed in 2.6.1.