Skip to main content
VulnerabilityPublished

CVE-2026-45034: PHPOffice PhpSpreadsheet · Deserialization of Untrusted Data

Affects PHPOffice PhpSpreadsheetSource CVE Database V5

0
Compare

Mentioned vulnerabilities

Not known to be exploited · CVSS 9.2 Critical : upgrade to 1.30.5 as a priority.

Data as of 5 Nov 2026, 00:01 UTC

CVSS 4.0 base score
9.2Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 40% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.30.5
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 22 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    Public exploit code: GitHub proofs of concept

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), GitHub proofs of concept, the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade PhpSpreadsheet and phpoffice/phpspreadsheet to 1.30.5.

Affected software

ProductAffectedFixed in
PHPOfficePhpSpreadsheetAffected
  • <1.30.5
Fixed in
  • 1.30.5
Packagistphpoffice/phpspreadsheetpkg:composer/phpoffice/phpspreadsheetOther threatsAffected
  • <1.30.5
Fixed in
  • 1.30.5

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade PhpSpreadsheet to version 1.30.5 or later, where this vulnerability is fixed. No other official remediation or temporary fix is documented. Users running PHP 7.x should prioritize patching due to the higher risk of automatic deserialization leading to RCE. For PHP 8.x, ensure that downstream code does not invoke Phar::getMetadata on untrusted inputs. Patch status is not explicitly stated as 'official-fix' in the advisory, but the vulnerability is fixed in version 1.30.5.

Description

PhpSpreadsheet is a pure PHP library for reading and writing spreadsheet files. Prior to 1.30.5, CVE-2026-34084 was patched by the helper File::prohibitWrappers. The helper calls parse_url($filename, PHP_URL_SCHEME) and then checks is_string($scheme) && strlen($scheme) > 1 to reject stream wrappers such as phar://, php://, data:// or expect://. The check is not equivalent to "does the path contain a wrapper". When the input has the form phar:///path/file.phar/inner with three or more slashes after the scheme, parse_url returns boolean false instead of returning the scheme string. The is_string($scheme) branch is therefore skipped, the helper returns without throwing, and the caller proceeds. PHP's stream layer, however, still treats phar:///... as a valid phar wrapper and opens the underlying phar file. The result is that IOFactory::load($attackerPath) walks past the patch and still touches the phar wrapper. On PHP 7.x, simply reaching the phar wrapper via is_file is enough for PHP to automatically deserialize the phar metadata, which in turn invokes the magic methods __wakeup and __destruct of an attacker controlled object and gives full RCE. On PHP 8.x, automatic metadata deserialization for plain file ops was removed, so the chain at the PhpSpreadsheet layer reduces to a phar wrapper file read primitive, and RCE only resurfaces if the downstream consumer ever calls Phar::getMetadata. This vulnerability is fixed in 1.30.5.

References

Community reviews

Loading reviews…