Skip to main content
VulnerabilityPublished

CVE-2026-70477: FlowiseAI Flowise · Code Injection

Affects FlowiseAI FlowiseSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 9.5 Critical : upgrade to 3.1.2 as a priority.

Data as of 2 Nov 2026, 10:58 UTC

CVSS 4.0 base score
9.5Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.8% chance of exploitation in 30 days – higher than 57% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.1.2, 3.1.3
CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2 Nov 2026.

What to do

Upgrade Flowise to 3.1.2; flowiseai/Flowise to 3.1.3.

Affected software

ProductAffectedFixed in
FlowiseAIFlowiseAffected
  • <3.1.2
Fixed in
  • 3.1.2
GitHubflowiseai/Flowisepkg:github/flowiseai/FlowiseOther threatsAffected
  • <3.1.3
Fixed in
  • 3.1.3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Flowise to version 3.1.3 or later, where this vulnerability is fixed. No other mitigations are specified. Patch status is confirmed fixed in 3.1.3.

Description

CVE-2026-70477 is a critical code injection vulnerability in FlowiseAI Flowise versions prior to 3.1.3. The flaw allows an attacker to send a crafted prompt to a chatflow using a CSV Agent node, causing the large language model to generate and execute malicious Python code in an unsandboxed Pyodide environment. This occurs because untrusted data is used to build the LLM prompt and the resulting code validation is bypassed. The vulnerability is fixed in version 3.1.3.

References

Community reviews

Loading reviews…