CVE-2026-69255: FlowiseAI Flowise · Code Injection
Affects FlowiseAI FlowiseSource CVE Database V5
Not known to be exploited · CVSS 9.2 Critical : upgrade to 3.1.3 as a priority.
Data as of 2 Nov 2026, 22:58 UTC
- EPSS
- 0.6% chance of exploitation in 30 days – higher than 48% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.1.3
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 4 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2 Nov 2026.
What to do
Upgrade Flowise and flowiseai/Flowise to 3.1.3.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| FlowiseAIFlowise | Affected
| Fixed in
|
GitHubflowiseai/Flowisepkg:github/flowiseai/FlowiseOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
This vulnerability is fixed in Flowise version 3.1.3. Users should upgrade to version 3.1.3 or later to remediate this issue. No other mitigation steps are indicated by the vendor advisory.
Description
CVE-2026-69255 is a critical code injection vulnerability in Flowise versions prior to 3.1.3. It arises from improper handling of attacker-controlled CSV data in the CSVAgent component, where unvalidated input is interpolated directly into executable Python code. This flaw allows an authenticated attacker to execute arbitrary operating system commands with root privileges in the Flowise container. The issue is fixed in version 3.1.3.
References
- github.com/FlowiseAI/Flowise/security/advisories/GHSA-vmv7-4m6c-3cg5 (opens in a new tab)
- github.com/FlowiseAI/Flowise/pull/6499 (opens in a new tab)
- github.com/FlowiseAI/Flowise/commit/f4e2794f6a576b94578f2fdafbf49c2fb304626c (opens in a new tab)
- github.com/FlowiseAI/Flowise/releases/tag/flowise%403.1.3 (opens in a new tab)