CVE-2026-69254: FlowiseAI Flowise · Code Injection
Affects FlowiseAI FlowiseSource CVE Database V5
Not known to be exploited · CVSS 9.4 Critical : upgrade to 3.1.3 as a priority.
Data as of 2 Nov 2026, 22:58 UTC
- EPSS
- 0.6% chance of exploitation in 30 days – higher than 52% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.1.3
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:HExploitation evidence
Disclosed: evidence found.
CVE published 4 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: evidence found.
Public exploit code: GitHub proofs of concept
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), GitHub proofs of concept, the Metasploit, Exploit-DB and nuclei-templates index as of 2 Nov 2026.
What to do
Upgrade Flowise and flowiseai/Flowise to 3.1.3.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| FlowiseAIFlowise | Affected
| Fixed in
|
GitHubflowiseai/Flowisepkg:github/flowiseai/FlowiseOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade Flowise to version 3.1.3 or later, where this vulnerability is fixed. No other mitigation or temporary workaround is documented. Patch status is confirmed fixed in 3.1.3.
Description
CVE-2026-69254 is a critical code injection vulnerability in FlowiseAI's Flowise prior to version 3.1.3. It allows an authenticated attacker with limited privileges to execute arbitrary system commands as root by exploiting improper control over JavaScript code execution options. The flaw arises from the executeJavaScriptCode() function merging caller-provided NodeVM options over default security settings, enabling escalation to full system command execution. This issue is fixed in Flowise version 3.1.3.
References
- github.com/FlowiseAI/Flowise/security/advisories/GHSA-3769-jgqc-cxm7 (opens in a new tab)
- github.com/FlowiseAI/Flowise/pull/6306 (opens in a new tab)
- github.com/FlowiseAI/Flowise/commit/3086cb7e323bb96c5a581d3232ef975b0d92183d (opens in a new tab)
- github.com/FlowiseAI/Flowise/releases/tag/flowise@3.1.3 (opens in a new tab)