Skip to main content
VulnerabilityPublished Updated

CVE-2026-45052: OpenIdentityPlatform OpenAM · Improper Authorization

Affects OpenIdentityPlatform OpenAMSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 9.3 Critical : upgrade to 16.1.1 as a priority.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
9.3Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.7% chance of exploitation in 30 days – higher than 55% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 16.1.1
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:L/SC:N/SI:L/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 15 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade OpenAM and openidentityplatform/OpenAM to 16.1.1.

Affected software

ProductAffectedFixed in
OpenIdentityPlatformOpenAMAffected
  • <16.1.1
Fixed in
  • 16.1.1
GitHubopenidentityplatform/OpenAMpkg:github/openidentityplatform/OpenAMOther threatsAffected
  • <16.1.1
Fixed in
  • 16.1.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade OpenAM to version 16.1.1 or later, where this vulnerability is fixed. No other mitigation is indicated by the vendor advisory. Patch status is confirmed fixed in 16.1.1.

Description

OpenIdentityPlatform OpenAM versions prior to 16.1.1 contain an improper authorization vulnerability in the Liberty Web Services SOAP receiver. This flaw allows unauthenticated remote attackers to write persistent entries into a user's Liberty Discovery store and the shared root-realm Discovery branch. The vulnerability arises because server-side handlers bypass LDAP and identity ACLs, using an internal administrative token for global paths. This can lead to manipulated service-routing or security-mechanism records in deployments consuming Liberty discovery data. The issue is fixed in version 16.1.1.

References

Community reviews

Loading reviews…