Skip to main content
VulnerabilityPublished

CVE-2026-45158: opnsense core · Argument Injection

Affects opnsense coreSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 9.1 Critical : upgrade to 26.1.8 as a priority.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
9.1Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 44% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 26.1.8
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade core and opnsense/core to 26.1.8.

Affected software

ProductAffectedFixed in
opnsensecoreAffected
  • <26.1.8
Fixed in
  • 26.1.8
GitHubopnsense/corepkg:github/opnsense/coreOther threatsAffected
  • <26.1.8
Fixed in
  • 26.1.8

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade OPNsense core to version 26.1.8 or later, where this vulnerability is fixed. Since the vendor advisory confirms the fix in 26.1.8, applying this official update is the recommended remediation.

Description

CVE-2026-45158 is a critical vulnerability in OPNsense core versions prior to 26.1.8. It involves improper neutralization of argument delimiters in a command, specifically in the DHCP configuration processing. Unsanitized user input is passed to a shell script, enabling remote code execution as root on the underlying FreeBSD operating system. This vulnerability is fixed in version 26.1.8. The CVSS score is 9.1, indicating a high severity with network attack vector, low attack complexity, and full impact on confidentiality, integrity, and availability.

References

Community reviews

Loading reviews…