Skip to main content
VulnerabilityPublished Updated

CVE-2026-45249: Apache ECharts · Cross-site Scripting

Affects Apache EChartsSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.1 Medium : upgrade to 6.1.0 when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
6.1Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.7% chance of exploitation in 30 days – higher than 54% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 6.1.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 25 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade Apache ECharts and apache/echarts and echarts to 6.1.0.

Affected software

ProductAffectedFixed in
Apache Software FoundationApache EChartsAffected
  • <6.1.0
Fixed in
  • 6.1.0
npmapache/echartspkg:npm/apache/echartsOther threatsAffected
  • <6.1.0
Fixed in
  • 6.1.0
npmechartspkg:npm/echartsOther threatsAffected
  • <6.1.0
Fixed in
  • 6.1.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in Apache ECharts version 6.1.0. Users and administrators should upgrade to version 6.1.0 or later to remediate this vulnerability. No official temporary or alternative mitigations are indicated in the provided data.

Description

Apache ECharts versions prior to 6.1.0 contain a cross-site scripting (XSS) vulnerability in the Lines series tooltip rendering logic. When using Lines series with tooltips and no custom tooltip.formatter, raw HTML content in series.data[i].name can be rendered without proper escaping, potentially allowing script execution. This vulnerability breaks the usual automatic HTML escaping convention in built-in tooltip formatters. The issue is fixed in version 6.1.0.

References

Community reviews

Loading reviews…