Skip to main content
VulnerabilityPublished Updated

CVE-2026-45290: CloudburstMC Network · Unthrottled Resource Allocation

Affects CloudburstMC NetworkSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.5 High : upgrade to 1.0.0.CR3-20260417.085727-30 soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 20% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.0.0.CR3-20260417.085727-30
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 5 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade CloudburstMC Network to 1.0.0.CR3-20260417.085727-30.

Affected software

ProductAffectedFixed in
CloudburstMCNetworkAffected
  • <1.0.0.CR3-20260417.085727-30
Fixed in
  • 1.0.0.CR3-20260417.085727-30

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade all affected CloudburstMC Network library instances to version 1.0.0.CR3-20260417.085727-30 or later. No other workarounds or mitigations are known or recommended. Patch status is not explicitly confirmed by a vendor advisory, but the description clearly states that upgrading to the specified version resolves the issue.

Description

Cloudburst Network provides network components used within Cloudburst projects. A vulnerability in versions prior to `1.0.0.CR3-20260417.085727-30` impacts publicly accessible software depending on the affected versions of Network and allows an attacker to exploit a vulnerability in Network to stall the netty event loop, rendering it inoperable. All consumers of the library should upgrade to at least version `1.0.0.CR3-20260417.085727-30`. There are no known workarounds beyond updating the library.

References

Community reviews

Loading reviews…