CVE-2026-45291: CloudburstMC Network · Improper Input Validation
Affects CloudburstMC NetworkSource CVE Database V5
Not known to be exploited · CVSS 7.5 High : upgrade to 1.0.0.CR3-20260418.124334-32 soon.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 18% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.0.0.CR3-20260418.124334-32
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 5 Jun 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade CloudburstMC Network to 1.0.0.CR3-20260418.124334-32.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| CloudburstMCNetwork | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
The only known mitigation is to upgrade the CloudburstMC Network library to version 1.0.0.CR3-20260418.124334-32 or later. No other workarounds are available. Patch status is not explicitly confirmed in the vendor advisory, but upgrading to the stated version is recommended to resolve the issue.
Description
Cloudburst Network provides network components used within Cloudburst projects. A vulnerability in versions prior to `1.0.0.CR3-20260418.124334-32` impacts publicly accessible software depending on the affected versions of Network and allows an attacker to exploit a bug in Network to close the parent netty channel, rendering it inoperable. All consumers of the library should upgrade to at least version `1.0.0.CR3-20260418.124334-32`. There are no known workarounds beyond updating the library.