CVE-2026-45361: Apache Airflow Google provider · Key Exchange Without Entity Authentication
Affects Apache Airflow Google providerSource CVE Database V5
Not known to be exploited · CVSS 8.1 High : upgrade to 22.0.0 soon.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.5% chance of exploitation in 30 days – higher than 48% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 22.0.0
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 25 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade Apache Airflow Google provider and apache-airflow-providers-google to 22.0.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Apache Software FoundationApache Airflow Google provider | Affected
| Fixed in
|
PyPIapache-airflow-providers-googlepkg:pypi/apache-airflow-providers-googleOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Users should upgrade to apache-airflow-providers-google version 22.0.0 or later, where SSH host-key verification is enabled by default.
Description
Apache Airflow Google provider versions before 22.0.0 have a vulnerability in the ComputeEngineSSHHook where SSH host-key verification is disabled by default. This exposes SSH traffic between Airflow workers and Compute Engine VMs to interception or modification by in-path attackers. Users are advised to upgrade to version 22.0.0 or later to address this issue.