CVE-2026-45413: 1Panel-dev MaxKB · Use of Weak Hash
Affects 1Panel-dev MaxKBSource CVE Database V5
Not known to be exploited · CVSS 6.9 Medium : upgrade to 2.9.1 when convenient.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.08% chance of exploitation in 30 days – higher than 0% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.9.1
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 26 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade MaxKB and 1panel-dev/MaxKB to 2.9.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| 1Panel-devMaxKB | Affected
| Fixed in
|
GitHub1panel-dev/MaxKBpkg:github/1panel-dev/MaxKBOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade MaxKB to version 2.9.1 or later, where the password storage mechanism has been fixed to use a stronger hashing algorithm. Since the vendor advisory confirms the fix in 2.9.1, applying this update fully mitigates the vulnerability. No other mitigation steps are indicated.
Description
CVE-2026-45413 affects MaxKB versions prior to 2.9.1, where user passwords are stored using unsalted MD5 hashes. This weak hashing method makes password hashes trivially crackable using rainbow tables or GPU-accelerated brute force tools. The vulnerability is fixed in version 2.9.1. The CVSS 4.0 score is 6.9, indicating a medium severity risk primarily due to local attack vector and no required privileges or user interaction.