Skip to main content
VulnerabilityPublished

CVE-2026-45426: Apache Airflow · Incorrect Authorization

Affects Apache AirflowSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 3.1 Low : upgrade to 3.2.2 when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
3.1Low
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 29% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.2.2
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 1 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade Apache Airflow to 3.2.2.

Affected software

ProductAffectedFixed in
Apache Software FoundationApache AirflowAffected
  • >=3.0.0 <3.2.2
Fixed in
  • 3.2.2
PyPIapache-airflowpkg:pypi/apache-airflowOther threatsAffected
  • =3.0.0
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade Apache Airflow to version 3.2.2 or later, where this authorization flaw is fixed. No other official remediation or temporary workaround is provided. Patch status is not explicitly stated in the vendor advisory content, but the recommendation to upgrade to 3.2.2 or later indicates an official fix is available in those versions.

Description

CVE-2026-45426 is an authorization vulnerability in Apache Airflow 3.0.0 affecting the Log server's JWT token validation. The issue arises because the Log server uses Python's str.lstrip() to verify the JWT's subject claim against the requested Dag ID, which incorrectly strips characters rather than matching prefixes. This allows an authenticated Airflow worker with a valid Log-server JWT for one Dag to access logs of other Dags whose names share characters from the original Dag's name, potentially leaking task output and error traces. The vulnerability impacts deployments relying on per-Dag log-access scoping, such as multi-team or shared-worker setups. The CVSS score is 3.1 (low severity).

References

Community reviews

Loading reviews…