Skip to main content
VulnerabilityPublished

CVE-2026-45430: backdrop-contrib/salesforce · Cross-Site Request Forgery (CSRF)

Affects backdrop-contrib/salesforceSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.1 High : upgrade to 1.x-1.0.1 soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
7.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 4% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.x-1.0.1
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 12 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade backdrop-contrib/salesforce to 1.x-1.0.1.

Affected software

ProductAffectedFixed in
Backdrop CMS contributed projectsbackdrop-contrib/salesforceAffected
  • <1.x-1.0.1
Fixed in
  • 1.x-1.0.1

AI-suggested

A patch is available for this vulnerability in version 1.x-1.0.1 of the Salesforce module for Backdrop CMS. Since this is a cloud-hosted service, the vendor typically manages remediation server-side. Users should verify with the vendor advisory that the patch has been applied to their instance. No additional user action is required if the vendor confirms mitigation.

Description

CVE-2026-45430 is a high-severity vulnerability in the Salesforce module for Backdrop CMS contributed projects (backdrop-contrib/salesforce) prior to version 1.x-1.0.1. The module fails to properly implement a random state parameter in the OAuth authorization flow, leaving it vulnerable to Cross-Site Request Forgery (CSRF) attacks. This weakness could allow an attacker to trick a user into performing unwanted actions with high confidentiality and integrity impact, though availability impact is low. The vulnerability affects the cloud-hosted service version of the module. A patch is available to address this issue, and since it is a cloud service, the vendor typically manages remediation server-side. There are no known exploits in the wild at this time.

References

Community reviews

Loading reviews…