Skip to main content
VulnerabilityPublished Updated

CVE-2026-45434: Apache OFBiz · Improper Authentication

Affects Apache OFBizSource CVE Database V5

0
Compare

Not known to be exploited · 21% EPSS · CVSS 9.8 Critical : upgrade to 24.09.06 as a priority.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
9.8Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
21.2% chance of exploitation in 30 days – higher than 97% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 24.09.06
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 19 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade Apache OFBiz and org.apache.ofbiz/ofbiz to 24.09.06.

Affected software

ProductAffectedFixed in
Apache Software FoundationApache OFBizAffected
  • <24.09.06
Fixed in
  • 24.09.06
Mavenorg.apache.ofbiz/ofbizpkg:maven/org.apache.ofbiz/ofbizOther threatsAffected
  • <24.09.06
Fixed in
  • 24.09.06

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade Apache OFBiz to version 24.09.06 or later, as this version contains the fix for the vulnerability. Patch status is confirmed by the vendor's recommendation to upgrade. No alternative mitigations or temporary fixes are indicated.

Description

CVE-2026-45434 is a critical improper authentication vulnerability in Apache OFBiz before version 24.09.06. The flaw exists in the password-change logic and can lead to remote code execution without requiring authentication. The vulnerability has a CVSS score of 9.8, indicating high impact on confidentiality, integrity, and availability. Users are advised to upgrade to Apache OFBiz version 24.09.06, which addresses this issue.

References

Community reviews

Loading reviews…