CVE-2026-45574: oviva-ag epa4all-client · Improper Certificate Validation
Affects oviva-ag epa4all-clientSource CVE Database V5
Not known to be exploited · CVSS 8.1 High : upgrade to 1.2.2 soon.
Data as of 30 Oct 2026, 06:59 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 3% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.2.2
CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 26 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade epa4all-client and oviva-ag/epa4all-client to 1.2.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| oviva-agepa4all-client | Affected
| Fixed in
|
| com.oviva.telematikepa4all-client | Affected
| Fixed in
|
Mavenoviva-ag/epa4all-clientpkg:maven/oviva-ag/epa4all-clientOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade the epa4all-client to version 1.2.2 or later, where the improper certificate validation vulnerability is fixed. Since this is a client-side vulnerability and not a cloud service, applying this official fix is necessary to prevent interception of sensitive data. Patch status is confirmed by the vendor's versioning information. No alternative mitigations are indicated.
Description
epa4all-client is the Java Client for epa4all / ePA 3.0 in the Telematik Infrastruktur. Prior to 1.2.2, an attacker on the network path between the ePA service and the Konnektor can present any TLS certificate (self-signed, expired, wrong CN) and intercept all SOAP traffic. This includes patient identifiers (KVNR), SMC-B card operations (authentication, signing), document content, and credential exchanges. This vulnerability is fixed in 1.2.2.